Back to overview
Downtime
Major System-wide outage
Jul 17, 2024 at 2:12pm UTC
Affected services
Website
Collection Accounts
Resolved
Jul 18, 2024 at 10:02pm UTC
Our services have fully recovered
Affected services
Updated
Jul 17, 2024 at 8:31pm UTC
We have worked out the issue with our hosting partner. Thank you for your patience.
Affected services
Updated
Jul 17, 2024 at 2:14pm UTC
Our hosting partner is experiencing an outage. We are waiting for updates from their technicians.
Affected services
Created
Jul 17, 2024 at 2:12pm UTC
We are experiencing a major system-wide outage on all primary services. We are consulting with our hosting partner to resolve this issues quickly.
Affected services